Author Topic: Yamaha SZR 660 running problem  (Read 1101 times)

Bigt

  • Guest
Yamaha SZR 660 running problem
« on: February 11, 2008, 10:31:05 PM »
Bike is an SZR660 Yamaha. The engine is an XT660 single with the twin carb setup. It's in good condition and low mileage, about 8K miles. It's been stood for at least 6 months with fuel in it, I think.
 
The problem is it won't rev at all. It's OK up to 3000 rpm but if I open the throttle too wide it just won't pull, it dies. It starts and ticks over lovely and sounds ace, nice and quiet.
 
I've tried the following :-
 
- stripped and cleaned the carbs, although there was no dirt or gunge to be seen
- took the fuel tap off and drained the tank
- put fresh fuel in
- new spark plug
- ran it without the air filter
- removed the vacuum part of the fuel tap and run with straight through fuel supply.

None of these have made any difference.
 
My best guess is it's a fueling problem but can't find anything obvious. I had expected the main carb (CV?) to be the problem. The diaphragm appears to be in good condition.
 
HELP!

Steve H

  • Hero Member
  • *****
  • Posts: 1814
Re: Yamaha SZR 660 running problem
« Reply #1 on: February 12, 2008, 07:44:36 AM »
Did you clean the emulsion tube in the CV carb, its sits just above the main jet and isnt obvious. If blocked it can make it run rich at larger throttle openings. The other possnbility is a leaking fuel pump, its bolted to the bottom of the tank. If its leaking it could suck straight fuel into the inlet manifold. Ive not heard of any pumps leaking but might be worth bypassing as a test.

Bigt

  • Guest
Re: Yamaha SZR 660 running problem
« Reply #2 on: March 09, 2008, 09:47:47 PM »
Thanks for the suggestion SteveH.

After stripping, checking, cleaning and rebuilding the carbs to no avail I tried a few different things. I've found by taking the large diameter air vent hose off the CV carb it runs great. Has anyone got any idea why this should happen?

bigt

Steve H

  • Hero Member
  • *****
  • Posts: 1814
Re: Yamaha SZR 660 running problem
« Reply #3 on: March 10, 2008, 10:10:32 AM »
I believe the pipe provides a reference pressure for the CV carb diaphragm. If it were blocked it could mess up the CV carb fuellling, I'm not quite sure where the pipe feeds from, does it have a filter inside the pipe that is blocked, if it feed from the airbox, is that clear ?.

guest146

  • Guest
Re: Yamaha SZR 660 running problem
« Reply #4 on: March 10, 2008, 03:07:57 PM »
Just check the see if the CV slide is stuck in the up position , I had similar problems and it was just. Gave all the symptoms of a blocked jet.

Ken